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"Could not encrypt the private key" in Enterprise

Created by: Brendan Bone
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Problem

Upon click "OK" in Enterprise Examiner Configuration, or in "Configure Agent Push" in FTK/AD Lab, you receive the following error:

Could not encrypt the private key.

 

Resolution

  1. Ensure you are specifying a PEM, encrypted P12, or ADP12 in the "Private Key" field
  2. Click "Apply"

 

Cause

You specified an unencrypted P12 for the "Private Key".

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