Follow

Bulk Action jobs are stuck with "Submitted" status

Created by: Brendan Bone
Created date:
Last Updated date:

Problem

Any jobs submitted via the Bulk Actions menu stay at the "Submitted" status in the Work List.

 

Resolution

On all involved machines:

  1. Log in to Windows using your Summation service account
  2. Open the Services snap-in (services.msc)
  3. Stop all AccessData services

On the machine with "WCF Services" and "Processing Services":

  1. Open Compute Management (compmgmt.msc)**
  2. Expand "Services and Application"
  3. Expand "Message Queuing"
  4. Expand "Private Queues"
  5. Delete all "accessdatagroup" and "asyncprocessingservices" queues (you may have to take ownership and modify Security permissions of the queues in order to delete them)
    **You may be able to use the attached "DeleteAsyncQueues.ps1" PowerShell script to delete all the necessary queues.
  6. Open Advanced System Properties (systempropertiesadvanced)
  7. Click "Environmental Variables"
  8. Under "User variables", double-click the "PATH" variable
  9. Make sure the path "C:\Program Files\AccessData\AsyncProcessingServices\bin" is at the very beginning of the "Variable value" field and click OK
  10. Under "System variables", double-click the "Path" variable
  11. Make sure the path "C:\Program Files\AccessData\AsyncProcessingServices\bin" is at the very beginning of the "Variable value" field and click OK

On all involved machines:

12. Reboot

On the machine with "WCF Services" and "Processing Services":

13. Confirm the "AsyncProcessingAppPool" application pool (5.6.3 and older) or the "Async Processing Services" service (6.0 and newer) is started

 

If the above steps do not work, you may need to uninstall and reinstall the "WCF Services", making sure they are set use your Summation service account credentials.

NOTE: Steps 1 thru 12 above apply to Summation Pro version 5.6.3 and earlier.

Summation Pro Version 6.x and later do not have message queues and do not have the "bin" folder.

Cause

  • The message queues are broken
  • The environmental variables are causing the wrong dependencies to be called
  • "WCF Services" and "Processing Services" were not installed correctly
  • Async is not started
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk