Follow

Server Busy Error

Created by: Justin Johns
Created date:
Last Updated date:

Problem

When attempting to open FTK/Lab or perform various actions in the application, a Windows error will appear with the error message below:

"This action cannot be completed because the other program is busy. Choose 'Switch to' to activate the busy program and correct the problem."

 

Note: Consider setting exclusions for the database engine port (e.g. port 5432 for Postgresql) in any firewall application (e.g. Windows Firewall). If the "server busy" error still persists after exclusions were added, then see the following resolutions.

 

Resolution

1. Disable the Revocation Checking Policy either locally or on the domain using the article linked here.

2. Upgrade to .NET Framework 4.0 or newer

3. Change the Revocation Settings through Internet Explorer settings:

 

Cause

The issue may be experienced on systems that are not connected to the internet and/or have an old version of .NET Framework.  The application is attempting to verify the signature on specific .NET libraries used by FTK/Lab and may not be able to access the revocation information through the internet.  .NET Framework 4.0 and newer versions do not exhibit this same behavior.  

This issue was observed with AD Lab 5.3 in an "offline" environment.  

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

  • Avatar
    Jordan Zeveney

    I have received the same error numerous times when the PostgreSQL Service on my License Server turns off. Simply turned the service back on and the error went away.

  • Avatar
    Marcus Wu

    It doesn't seem that one can simply "disable" revocation checking as described above. I see options to configure those settings, but I see no options to outright disable it, at least not as indicated in the referenced Technet article. Also, can we safely assume the intent was to disable revocation checking on the Database machine, not the FTK machine?

Powered by Zendesk