Follow

AD Enterprise/AD Lab/FTK can't push modules

Created by: Brendan Bone
Created date:
Last Updated date:

Problem

All "Add Remote Data" jobs fail because FTK is not pushing the necessary modules.  This can be verified by the "C:\Program Files\AccessData\Agent\modules" folder being empty on the Agent target machine.

 

Resolution

  1. Verify that the Examiner machine is able to communicate with the Agent target over port 3999
  2. Verify that SSL traffic is allowed over port 3999
  3. In FTK, go to Tools > Configure Agent Push
  4. Ensure the following paths are set correctly:
    Path to UNC share: \ADMIN$\temp
    Local path to shard folder: %systemroot%\temp
    Path to trusted modules certificate: <FTK_Installation_Folder>\<version>\bin\Agent\modules\adata.p7b
    Path to agent modules: <FTK_Installation_Folder>\<version>\bin\Agent\modules
  5. Restart FTK
  6. Uninstall the Agent from the target machine
  7. Re-install the Agent to the target machine

 

Note

For software or Agent versions prior to 6.0, this may also be caused by the old adata certificate expiring.

Cause

FTK may not be able to properly push or communicate with the modules because the paths in "Configure Agent Push" are incorrect, or the wrong module certificate is being used.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk