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Searching Issue after Upgrade or creating custom field (may receive error: argument_addingDuplicate)

Created by: Tod Ewasko
Created date:
Last Updated date:

Problem

If you create custom fields that have the same name as Summation Pro default system fields, search will fail on that specific case. The following error may appear in the "System Log".

Query Parser Error:[Argument_AddingDuplicate]

 

Cause

When Summation Pro returns the results to the Summation grid, it attempts to add all the columns in the background for performance reasons. Duplicate fields in this process will cause the grid to be blank.

Tags:

addingduplicate, unable to search, search fails


Resolution

Rename or delete the custom fields created. As a best practice workflow, if you append all your custom fields with a 'aa' or 'zz', they will be grouped into an area when you get in review. After renaming you will have to clear your browser cache.

NOTE:

The attached T-SQL script will check all of the case databases for custom field display names that duplicate a non-virtual system field name. Any custom fields that cause this issue will have 'Custom' prepended onto the field name (e.g., a custom field named "Issues" would be renamed "CustomIssues").

The script can be run in Microsoft SQL Management Studio.

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Comments

  • Avatar
    Vaughn Kellington

    Can you please call me to discuss this issue. My number is (403) 294-7053.

  • Avatar
    Tod Ewasko

    Vaughn we understand you got what you requested on this post. correct?

  • Avatar
    Vaughn Kellington

    This issue has now been resolved. Thank you!

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